^WeSt commented on a Page, Advanced Google Bot Search  -  Oct 06, 2013

Not working on me! i have done +Google but when i use !google only return me an notice that said: Searching Google........
But no results appeared...

FordLawnmower  -  Oct 06, 2013

I still have this working 100% ^West. I don't see any problems scanning the code here. Pls. try loading the code from here to make sure: http://scriptbin.net/view/2bc2b6d3
If this works for you I will update the code here.

^WeSt  -  Oct 08, 2013

Well i try it from your url but still not working man, had an mini-test to on my currently bot i set a timer for msg the command: /timer 1 10 msg #test_chan !google IRC well after this i gone to my bot and using /socklist command to see if the add-on opens the socks the socks have been opened have a look into the socks. ALSO i have try it to an Clean mIRC with not any addons,dlls,aliases and still have this problem, stucking into the Searching.. notice!


  • Open sockets:
  • GTinyUrlIRC9302222859544702 tinyurl.com:80 tcp connecting
    GTinyUrlIRC9302222885988378 tinyurl.com:80 tcp connecting
    GTinyUrlIRC9302222810312678 tinyurl.com:80 tcp connecting
    GTinyUrlIRC9302222819507000 tinyurl.com:80 tcp connecting

Also with the /google IRC command the /socklist result was:

GTinyUrlIRC9373864788866108 tinyurl.com:80 ( tcp active (on: .146.243.84 57084)
GTinyUrlIRC9373864711705585 tinyurl.com:80 ( tcp active (on:
.146.243.84 57085)

NOTE: i am using 7.32 mIRC version!!!!!

  • Thanks!
FordLawnmower  -  Oct 09, 2013

It sounds like you have an issue with tinyurl. Perhaps they are blocking you for some reason.
Try changing the var UseTinyURL to 0

;;Change %UseTinyURL(below) if you don't want links converted to tinyurl. Valid numbers are: 1 for convert and 0 for don't convert.
var %UseTinyURL 1

If this works , I can make an edit for you that uses a different link shortener. I have made a few of these because tinyurl is blocked by some countries.

^WeSt  -  Oct 09, 2013

Yes you're right now work perfect! i set it to 0 and worked!

FordLawnmower  -  Oct 09, 2013

What country are you in @^WeSt ?

^WeSt  -  Oct 09, 2013

Greece (Flag :P)

^WeSt  -  Oct 09, 2013

Also if you have a way to make the google commands to work without an +google or any other command to enable/disable the google just if anyone uses the command to display the results.

  • Thanks!
^WeSt  -  May 10, 2014

I found an way to work the tinyurl using %UseTinyURL 1 i have just edit an other code and thinking to change and yours so i try and find an way with this code mine is working , check it and if it is working and with yours so you can replace it.

On :sockread:GTinyUrl: {
if ($sockerr) { sockclose $sockname | return }
else {
sockread -f &tiny | var %tiny $bvar(&tiny,1-).text
var %tiny2 = $remove($gettok(%tiny,$numtok(%tiny,32),32),close,$crlf)
if (http://* iswm %tiny2) {
tokenize 32 $sock($sockname).mark
$1-2 $replace($5-,$4,%tiny2)
sockclose $sockname

Sign in to comment

Are you sure you want to unfollow this person?
Are you sure you want to delete this?
Click "Unsubscribe" to stop receiving notices pertaining to this post.
Click "Subscribe" to resume notices pertaining to this post.