FordLawnmower commented on a Page, Twitter TweetBot  -  Jun 09, 2013

Updated to comply with the new Twitter api 1.1
I also found a bug that was causing 401 Unauthorized. I had no url encoding on passwords, so if they had special characters it generated a 401.

PackardBell  -  Jun 10, 2013

tried the new script:
[10/06/13|13:25:15] Password/Username Error --> HTTP/1.1 401 Unauthorized
[10/06/13|13:25:15] You must supply your twitter information to me in private. Syntax: .AddAuth username:password
[10/06/13|13:25:15] You may also use the more secure method if you are using mIRC by typing in the following in MY Query window.
[10/06/13|13:25:15] //say .AddAuth $encode(username:password,m)

still won't work @FordLawnmower

FordLawnmower  -  Jun 11, 2013

I've tested this with no issues @PackardBell . Did you follow the instructions ?

PackardBell  -  Jun 12, 2013

yeah, if finally works. :) Thx a lot!

RicJames  -  Jun 12, 2013

How did you get it to work? I'm getting the same error. My password has a ! in it.

FordLawnmower  -  Jun 12, 2013

@RicJames . I have tested the script with ! in passwords, with no issues.
Are there any other special characters in your password or username ?
Did you follow the instructions ?

RicJames  -  Jun 13, 2013

I followed the instructions 100%, the only other thing is some numbers.

PackardBell  -  Jun 13, 2013

A friend of mine tried it today. He kinda failed with the $encode shizzle. But it works.
1 remark: try change your name with twittername and check out ;)

FordLawnmower  -  Jun 13, 2013

@PackardBell . I'm not sure what you are talking about. You have to use your real twitter screenname to authenticate.
It's not possible to change your screenname.

FordLawnmower  -  Jun 13, 2013

@RicJames . There are no issues with numbers in passwords. I need something more to go on to help you.
Are you using a old version of mIRC ?
Do you still have an old version of this script loaded ?
Have you tried loading the script to a clean mIRC, with no other scripts ?

PackardBell  -  Jun 13, 2013

@FordLawnmower I know you can't change it. But some people mix them up while trying to auth.

FordLawnmower  -  Jun 13, 2013

I understand you now :)

RicJames  -  Jun 13, 2013

I tried it with another clean mirc and it worked. I guess that means one of my snippet's is conflicting with the process. Any idea what kind of script would cause the conflict?

FordLawnmower  -  Jun 13, 2013

I would guess that it's another version of this same script @RicJames .
Try searching from the scripts editor for twitter_statuses_update . Check the box that says "Search all files in this section"
If you have more than one file using sockets with this name, it will cause a problem.
mIRC will use the one that was loaded first.

Sign in to comment

Are you sure you want to unfollow this person?
Are you sure you want to delete this?
Click "Unsubscribe" to stop receiving notices pertaining to this post.
Click "Subscribe" to resume notices pertaining to this post.